System Requirements

In this article

What do I need to use Transpond?

Transpond is a Cloud Based application which means all you need is a modern web browser to use it. Choose your favorite browser from our list of supported browsers and you’re good to go.

Browser Support Policy

Modern browsers are safer, faster, more reliable, and will provide you with a better experience when using Capsule. Our policy is to support:

  • The latest version of Google Chrome, Firefox and Microsoft Edge, all of which automatically update when they detect a new version of the browser is available.
  • Current and previous major releases of Safari. So for example when Safari 14 was released, we dropped official support for Safari 12 and just support Safari 13 and 14.

Current Browser Support

  • Google Chrome (latest version)
  • Firefox (latest version)
  • Microsoft Edge (latest version)
  • Safari (13+)
Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.